2007年8月2日木曜日

MySQL 4.0系では、副問い合わせができない

今回は、タイトルの通り。
MySQL 4.0 系では、副問い合わせができないのである。
 
副問い合わせを使っている SQL 文が、ローカル環境の 5.x と 4.1.x では問題ないのに、4.0.21でだけ構文エラーが出ていたので、もしやと思い調べてみたら案の定だった。
 
なんというトラップ。
未だにこのいにしえ 4.0.x 系の MySQL を導入しているレンタルサーバがあるので(今回被害にあったの所もそう)、サーバーをレンタルする際には MySQL はもちろん、その他のサービスのヴァージョンには充分注意したい
まったく、こんなことで2時間ほど悩んでいた自分が情けなくなってくる。気持ち悪い
 
 
参考サイト

0 件のコメント:

コメントを投稿